Delays in email responses
Incident Report for x.ai
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 09, 2018 - 21:06 UTC
Investigating
We are currently experiencing delays in Amy and Andrew's responses.
Posted about 1 month ago. Jan 09, 2018 - 20:44 UTC