My.x.ai down
Incident Report for x.ai
Resolved
My.x.ai is back up and fully functional
Posted about 1 month ago. Jan 22, 2018 - 16:38 UTC
Investigating
My.x.ai is down and we are currently investigating the cause
Posted about 1 month ago. Jan 22, 2018 - 16:23 UTC