Delays in email responses
Incident Report for
The issue has been resolved and response times are back to normal.

We deployed code that caused emails to be blocked from successfully running through our email processor. We reverted that code change and the related intermediate data that was created. After we did that, we were able to resume processing emails normally, but had generated a very significant backlog that took about 2 hours to work through.
Posted about 1 month ago. Feb 21, 2018 - 20:25 UTC
We are monitoring an issue with our email receiver and processor causing Amy and Andrew to take longer than normal to respond. A fix has been put in place.
Posted about 1 month ago. Feb 21, 2018 - 19:26 UTC