Delayed Email Reponses
Incident Report for x.ai
Resolved
We've pushed a fix and are now processing all emails. You may still see some delay in responses as the system fully recovers.
Posted about 1 year ago. Apr 25, 2018 - 16:57 EDT
Investigating
We are investigating an error that is preventing emails from being processed in our system. Amy and Andrew will take longer than usual to respond to requests.
Posted about 1 year ago. Apr 25, 2018 - 16:46 EDT