Intermittent Email Processing Delays
Incident Report for x.ai
Resolved
This incident has been resolved.
Posted 6 months ago. Jul 13, 2018 - 09:41 EDT
Update
We are continuing to work on a fix for this issue.
Posted 6 months ago. Jul 13, 2018 - 08:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Jul 13, 2018 - 08:55 EDT
Investigating
Our email provider is experiencing issues.
Posted 6 months ago. Jul 13, 2018 - 08:53 EDT
This incident affected: Email Processing (email sender).