Delayed Email Responses
Incident Report for x.ai
Resolved
We've resolved the issue causing email delays, but you may still experience lags in response time as the system fully recovers.
Posted about 1 year ago. Apr 23, 2018 - 17:56 EDT
Investigating
We are currently investigating longer than usual delays with Amy and Andrew's responses.
Posted about 1 year ago. Apr 23, 2018 - 16:58 EDT