Mail delivery system down
Incident Report for x.ai
Resolved
This incident has been resolved.
Posted 21 days ago. Oct 02, 2019 - 10:14 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 21 days ago. Oct 02, 2019 - 10:11 EDT
Investigating
Our mail delivery service is down, Amy is not able to receive emails. Fix in approximately half an hour.
Posted 21 days ago. Oct 02, 2019 - 09:52 EDT
This incident affected: Email Processing (email receiver).