Delayed Email Responses
Incident Report for x.ai
Resolved
This incident has been resolved.
Posted about 1 year ago. May 07, 2018 - 11:54 EDT
Identified
We are investigating an error that is preventing emails from being processed in our system. Amy and Andrew will take longer than usual to respond to requests.
Posted about 1 year ago. May 07, 2018 - 10:17 EDT
This incident affected: Email Processing (email processor).