Delayed email processing
Incident Report for x.ai
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 10:37 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2020 - 19:54 EDT
Investigating
We are currently investigating this issue.
Posted Oct 08, 2020 - 13:23 EDT
This incident affected: Email Processing (email processor, email sender).