Partial outage: Email delivery service (Mailgun) experiencing issues
Incident Report for x.ai
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 12:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2021 - 10:17 EDT
Investigating
Our email delivery provider is currently experiencing an issue that is causing delays with email delivery. Based on their current public status, we can see that they're identified the issue and working on a fix.

Mailgun Status: https://status.mailgun.com/
Posted Jun 03, 2021 - 10:02 EDT
This incident affected: Email Processing (email receiver, email processor, email sender).